PDA

View Full Version : Windows 7 and .NET Framework 3.5 problem


tedwards0118
06-18-2012, 09:56 AM
I cannot seem to locate Framework 3.5 SP1 for Windows 7 on MS support site. Is Framework 3.5 only for other MS operating systems? I have Framework 4.0 installed but Ninja Trader is not working.


Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: ninjatrader.exe
Problem Signature 02: 7.0.1000.10
Problem Signature 03: 4fd0ac13
Problem Signature 04: NinjaTrader.Core
Problem Signature 05: 7.0.1000.10
Problem Signature 06: 4fd0ac28
Problem Signature 07: 22e7
Problem Signature 08: 0
Problem Signature 09: System.ArgumentException
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033

NinjaTrader_Joydeep
06-18-2012, 10:01 AM
Hello tedwards0118,
Welcome to the forum and I am happy to assist you.

Please follow the instructions below to repair Microsoft .NET Framework 4 on your PC.

Download and run the .Net 4 installer from below. http://www.microsoft.com/downloads/en/confirmation.aspx?FamilyID=9cfb2d51-5ff4-4491-b0e5-b386f32c0992&displaylang=en

Once ran you will receive two options if .Net 4 is installed.

Select "Repair .Net Framework 4 to its original state"

Click "Next" and follow other prompts

Once the setup application is finished it may ask you to restart your computer, even if it does not please do so.

Please retest your issue and see if it is resolved.

tedwards0118
06-18-2012, 10:26 AM
I repaired .NET Framework 4.0 and restarted my computer. I get the same problem when trying to run Ninja Trader in 64 bit mode or 32 bit mode.

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: ninjatrader.exe
Problem Signature 02: 7.0.1000.10
Problem Signature 03: 4fd0ac13
Problem Signature 04: NinjaTrader.Core
Problem Signature 05: 7.0.1000.10
Problem Signature 06: 4fd0ac28
Problem Signature 07: 22e7
Problem Signature 08: 0
Problem Signature 09: System.ArgumentException
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033

NinjaTrader_Joydeep
06-18-2012, 11:01 AM
Hello tedwards0118,
Please uninstall .Net Framework 4 from your PC and install .Net Framework 3.5 SP1 from the below link
http://www.microsoft.com/en-us/download/details.aspx?id=22

You can install .Net framework once you have installed .Net Framework 3.5 SP1

Please let me know if I can assist you any further.

tedwards0118
06-18-2012, 12:39 PM
Windows 7 is not a supported operating system for Framework 3.5 SP1 in the link you provided. I'll try anyway....

tedwards0118
06-18-2012, 02:35 PM
Nothing is working... addition info: I'm using Windows 7 on a Mac running Parallels.

NinjaTrader_RyanL
06-18-2012, 03:22 PM
Hello tedwards0118,

While we do not officially support running NinjaTrader on a Mac; we have had many clients run NinjaTrader on Mac hardware. We have specific installation instructions for Parallels and VMWare Fusion which will allow you to run NinjaTrader on your Mac.



Below you will find instructions specific to the available options of running NinjaTrader on a Mac computer.




If you are using Parallels 6, please contact us for specific instructions. http://kb.parallels.com/en/4923


Mac Installation - Configuring NinjaTrader for Parallels 7:
When installing NinjaTrader on a Mac using Parallels 7, users will need to ensure that the following steps have been taken prior to the installation of NinjaTrader.


Start Parallels and select your virtual machine
Press the "Configure" button on the top
Under "Options", select "Sharing"
Uncheck "Share Mac" under "Share Mac User Folders with Windows"
Press "OK" and start the virtual machine



Please let me know if you are able to resolve the situation by configuring Parallels as per the instructions above, or if I can provide any further assistance.

tedwards0118
06-18-2012, 05:36 PM
Okay...that worked! I am using Framework 4.0 with Windows 7 on a Mac with Parallels and shared folders disabeled.

Thanks!